We are investigating
Minor incident
Explorer
2023-08-14 22:54 UTC
·
2 minutes
Updates
Resolved
August 14, 2023 · 22:56 UTC
We found the root of the issue and we have fixed it.
Issue
August 14, 2023 · 22:54 UTC
We have detected issues and we are currently investigating, we’ll update you soon.
← Back