We are investigating
Minor incident
Explorer
2023-08-02 20:01 UTC
·
35 seconds
Updates
Resolved
August 2, 2023 · 20:02 UTC
We found the root of the issue and we have fixed it.
Issue
August 2, 2023 · 20:01 UTC
We have detected issues and we are currently investigating, we’ll update you soon.
← Back